Distance(ThisObject.X, ThisObeject.Y, ThatObject.X, ThatObject.Y)
Distance(ThisObject.Point, ThatObject.Point)
Distance(ThisObject, ThatObject)
Last one looks cleanter, IMHO.
If the expression can extract X and Y out of the object, it looks cleaner than the "point" alternative and avoids creating yet another construct.